Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Subset of SMS Are Undelivered to MTN Nigeria
Incident Report for Twilio
Resolved
SMS delivered to the MTN network in Nigeria has been stable without any issues. The in-region carrier partners have provided final confirmation that the issue is fixed. This incident is now resolved.
Posted Jul 01, 2020 - 23:10 PDT
Monitoring
SMS are now getting delivered to the MTN network in Nigeria. We' will continue to monitor the situation until we have final confirmation from in-region carrier partners that the issue is completely resolved. We will provide an update as soon as we have more information.
Posted Jul 01, 2020 - 22:27 PDT
Update
We are continuously working with our carrier partners in the region to resolve the issue. We will provide an update as soon as we have more information.
Posted Jul 01, 2020 - 20:29 PDT
Update
We are continuously working with our carrier partners in the region to resolve the issue. We will provide an update as soon as we have more information.
Posted Jul 01, 2020 - 18:29 PDT
Investigating
We are observing a subset of SMS sent to the MTN network in Nigeria are undelivered. Our engineers are working with our carrier partners in the region to resolve the issue. We will provide an update as soon as we have more information.
Posted Jul 01, 2020 - 17:29 PDT
This incident affected: CARRIER NETWORK (SMS, Middle East & Africa).