Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Error Retrieving the Usage Data in the Twilio Console
Incident Report for Twilio
Resolved
Our engineers have identified an issue with the code causing the elevated errors within the Twilio Console Usage page. A fix has been deployed and has corrected the issue. This incident has been resolved.
Posted Jun 30, 2020 - 21:58 PDT
Update
We are continuously investigating the elevated errors when accessing the usage page in the console. We will provide an update as soon as possible.
Posted Jun 30, 2020 - 20:48 PDT
Update
We are continuing to investigate the elevated errors when accessing the usage page in the console. We will provide an update as quickly as possible.
Posted Jun 30, 2020 - 19:45 PDT
Update
We are investigating elevated errors when accessing the usage page in the console. We will provide an update as quickly as possible.
Posted Jun 30, 2020 - 19:05 PDT
Investigating
We have discovered a potential issue. Our team is investigating the issue and we will provide an update as soon as we have more information.
Posted Jun 30, 2020 - 18:37 PDT
This incident affected: TWILIO PLATFORM (Console).