Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Message Delivery Report Delays to the US Sprint Network from Twilio Short Codes and Inbound SMS Message Failures from US Sprint to Twilio Short Codes
Incident Report for Twilio
Resolved
We are no longer experiencing delivery report delays when sending to the US Sprint network from Twilio short codes. This incident has been resolved.
Posted Mar 25, 2021 - 13:01 PDT
Monitoring
We are observing recovery in delivery report delays when sending to the US Sprint network from Twilio short codes. We are also seeing successful recovery for inbound SMS messages sent from US Sprint to Twilio short codes for the last 1 hour and 20 minutes. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Mar 25, 2021 - 11:08 PDT
Update
Our carrier partner has informed us that a subset of SMS messages sent from US Sprint to Twilio short codes may not be received. We also continue to experience delays in receiving SMS message delivery reports when sending to the US Sprint network from Twilio short codes. Our engineers are still working with our carrier partner to resolve the issue. We expect to provide another update in 16 hours or as soon as more information becomes available.
Posted Mar 24, 2021 - 23:43 PDT
Update
Our carrier partner has informed us that a subset of SMS messages sent from US Sprint to Twilio short codes may not be received. We also continue to experience delays in receiving SMS message delivery reports when sending to the US Sprint network from Twilio short codes. Our engineers are still working with our carrier partner to resolve the issue. We expect to provide another update in 8 hours or as soon as more information becomes available.
Posted Mar 24, 2021 - 15:43 PDT
Update
Our carrier partner has informed us that a subset of SMS messages sent from US Sprint to Twilio short codes may not be received. We also continue to experience delays in receiving SMS message delivery reports when sending to the US Sprint network from Twilio short codes. Our engineers are still working with our carrier partner to resolve the issue. We expect to provide another update in 4 hours or as soon as more information becomes available.
Posted Mar 24, 2021 - 11:42 PDT
Update
We continue to experience delays in receiving SMS message delivery reports when sending to the Sprint network in the US from Twilio short codes. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Mar 24, 2021 - 10:46 PDT
Update
We are experiencing delays in receiving SMS message delivery reports when sending to the Sprint network in the US from Twilio short codes. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Mar 24, 2021 - 09:55 PDT
Investigating
Our monitoring systems have detected a potential issue with SMS delivery report delays to the Sprint network in the US from Twilio short codes. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Mar 24, 2021 - 09:33 PDT
This incident affected: CARRIER NETWORK (SMS Short Code, North America, SMS Delivery Notifications & Status Callbacks).