Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Intermittent Inbound Delivery Delays to a Small Percentage of Non-US Numbers
      Incident Report for Twilio
      Resolved
      All services are operating normally.
      Posted Dec 04, 2016 - 22:06 PST
      Monitoring
      At this time, the connections with our carrier partners are back to normal. We are continuing to monitor the situation until we can confirm that any delayed messages are delivered.
      Posted Dec 04, 2016 - 18:10 PST
      Identified
      Our carrier partners have identified the issue causing the intermittent delays. It is related to network maintenance at a downstream internet service provider, and could take up to 4 hours and 15 minutes to resolve. We are continuing to work with our carrier partners and will provide another update within two hours.
      Posted Dec 04, 2016 - 16:47 PST
      Investigating
      We are currently seeing intermittent inbound delivery delays to a small percentage of non-US Twilio numbers. We are investigating this issue with our carrier partners. We will provide another update in two hours.
      Posted Dec 04, 2016 - 15:37 PST
      This incident affected: PROGRAMMABLE MESSAGING (SMS).