Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Some Super SIM customers experiencing connectivity issues
Incident Report for Twilio
Resolved
The connectivity issues have been resolved and Super SIMs are operating normally at this time.
Posted Sep 26, 2020 - 04:12 PDT
Update
We are continuing to monitor for service stability. We will provide another update in 30 minutes or as soon as more information becomes available.
Posted Sep 26, 2020 - 03:57 PDT
Monitoring
We have experienced a drop in Super SIM connectivity at 00:10 am PT of about 15% with one of our partners. We are seeing recovery since 02:15 am PT. We are continuing to monitor for service stability. We will provide another update in 1 hour or sooner once more information becomes available.
Posted Sep 26, 2020 - 03:18 PDT
Investigating
Our monitoring systems have detected a potential issue with Super SIMs. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Sep 26, 2020 - 03:02 PDT
This incident affected: INTERNET OF THINGS (Super SIM).