Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS delivery to Etisalat Egypt handsets is degraded.
Incident Report for Twilio
Resolved
We have observed a recovery in delays sending SMS to Etisalat handsets in Egypt. We will continue monitoring and will resolve this incident.
Posted 17 days ago. Apr 07, 2019 - 09:52 PDT
Monitoring
We are observing a steady recovery in delays sending SMS to Etisalat handsets in Egypt. We are actively working with our carrier partner to resolve the issue. We will provide a next update as soon as possible.
Posted 17 days ago. Apr 07, 2019 - 07:07 PDT
Investigating
We are observing delays in sending SMS to Etisalat handsets in Egypt. We are actively working with our carrier partner to resolve the issue. We will provide an update as soon as possible.
Posted 17 days ago. Apr 07, 2019 - 04:35 PDT
This incident affected: CARRIER NETWORK (SMS, Middle East & Africa).