Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Duplicate MMS Messages Sent On Subset of US Short Codes
Incident Report for Twilio
Resolved
We have confirmed that the issue related to duplicate MMS messages is resolved.
Posted 18 days ago. Jul 02, 2019 - 01:10 PDT
Update
We continue to see that, in some cases, a subset of our US short codes are sending duplicate MMS text messages. We have escalated this issue with our carrier partner. We will let you know as soon as we have more information.
Posted 18 days ago. Jul 01, 2019 - 21:17 PDT
Investigating
We have detected an issue that, in some cases, a subset of our US short codes are sending duplicate MMS text messages. We are working with our carrier partner to resolve this issue and will provide more information as soon as available.
Posted 18 days ago. Jul 01, 2019 - 11:45 PDT
This incident affected: CARRIER NETWORK (MMS Short Code, North America).