Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Delays To Multiple Destination Via A Subset Of Alphanumeric Sender ID And Longcode
      Incident Report for Twilio
      Resolved
      We are no longer experiencing SMS delivery delays to multiple destinations via a subset of alphanumeric sender ID's and longcodes. The incident has been resolved.
      Posted Nov 18, 2024 - 11:35 PST
      Update
      We continue to observe recovery in SMS delivery delays to multiple destinations via a subset of alphanumeric sender ID's and longcodes. We will continue to monitor the service to ensure a full recovery. We will provide another update within 2 hours or as soon as more information becomes available.
      Posted Nov 18, 2024 - 09:48 PST
      Monitoring
      We are observing recovery in SMS delivery delays to multiple destinations via a subset of alphanumeric sender ID's and longcodes. We will continue to monitor the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Nov 18, 2024 - 07:43 PST
      Update
      We are still experiencing SMS delivery delays to Multiple destinations via a subset of Alphanumeric Sender ID And Longcode. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Nov 18, 2024 - 05:58 PST
      Investigating
      We are experiencing SMS delivery delays to Multiple destinations via a subset of Alphanumeric Sender ID And Longcode. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted Nov 18, 2024 - 04:59 PST
      This incident affected: CARRIER NETWORK (SMS Long Code, North America, SMS, Europe) and Sender ID.