Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Issues to Asia Cell Iraq Handsets
      Incident Report for Twilio
      Resolved
      We have confirmed that we are no longer experiencing delivery degradation to Asia Cell Telecommunications handsets in Iraq. All services are operating normally.
      Posted Jul 17, 2019 - 12:21 PDT
      Monitoring
      We are observing that we are seeing recovery in delivering SMS to Asia Cell Telecommunications handsets in Iraq. We will continue to monitor and provide an update.
      Posted Jul 17, 2019 - 11:05 PDT
      Investigating
      We are experiencing SMS delivery issues to Asia Cell Telecommunications handsets in Iraq. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
      Posted Jul 17, 2019 - 07:12 PDT