Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery delays to PCCW in Hong Kong
      Incident Report for Twilio
      Resolved
      SMS Messages to PCCW subscribers in Hong Kong are now operating normally
      Posted May 15, 2017 - 12:02 PDT
      Update
      Twilio started to receive delivery receipts from the mobile PCCW in Hong Kong. We continue to monitor this carrier.
      Posted May 15, 2017 - 11:16 PDT
      Monitoring
      The issue has been resolved by the network operator, at the moment SMS are being delivered without any delays. We still see delays in the delivery receipts, however it’s not affecting the actual message delivery.
      Posted May 15, 2017 - 08:05 PDT
      Identified
      The issue has been identified, the PCCW network provider is expiriecing issues with delivery capacity, resulting SMS to this network being delayed
      Posted May 15, 2017 - 07:48 PDT
      Investigating
      We are investigating SMS delivery delays to PCCW mobile phones in Hong Kong
      Posted May 15, 2017 - 06:20 PDT
      This incident affected: PROGRAMMABLE MESSAGING (SMS).