The High latency issue on outgoing messages for Programmable Messaging API has been resolved and service is operating normally at this time.
Posted Mar 18, 2026 - 18:01 PDT
Monitoring
The High latency issue on outgoing messages for Programmable Messaging API is now operating normally. We will continue to monitor for system stability. We'll provide another update in 2 hours or as soon as more information becomes available.
Posted Mar 18, 2026 - 15:52 PDT
Update
We are experiencing High latency impacting sending outgoing messages for Programmable Messaging API. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Mar 18, 2026 - 14:47 PDT
Investigating
Our monitoring systems have detected a potential issue with High latency impacting outgoing messages for msg-send. Our engineers have been alerted and are investigating. We will provide an update when we have more details.
Posted Mar 18, 2026 - 14:31 PDT
This incident affected: PROGRAMMABLE MESSAGING (Programmable Messaging API).