Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Flex Account Creation Does Not Trigger Flex Setup
Incident Report for Twilio
Resolved
Issues pertaining to Flex account creation have been resolved, and Flex account creation is operating normally at this time.
Posted Sep 03, 2021 - 09:43 PDT
Monitoring
Flex account creation is now operating normally. We will continue to monitor for system stability. We'll provide another update in 30 minutes or as soon as more information becomes available.
Posted Sep 03, 2021 - 09:22 PDT
Update
We are still seeing degraded performance on our account portal with regards to the creation of Flex accounts. Our engineering team is looking into the issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Sep 03, 2021 - 07:30 PDT
Investigating
We are currently seeing degraded performance on our account portal with regards to the creation of Flex accounts. Our engineering team is looking into the issue. We expect to provide another update in 60 minutes or as soon as more information becomes available.
Posted Sep 03, 2021 - 06:30 PDT
This incident affected: FLEX (Flex Application Platform).