Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Status Receipt Delivery Failures to Verizon Handsets in the United States
      Incident Report for Twilio
      Resolved
      Message status receipts for long codes sent to Verizon handsets in the United States are now being delivered successfully
      Posted Sep 25, 2018 - 17:49 PDT
      Investigating
      We are currently not receiving message status receipts for long codes sent to Verizon handsets in the United States. Message delivery is not affected. All Twilio services are fully operational. We are working with our carrier partner and will provide an update as soon as we have more information.
      Posted Sep 25, 2018 - 15:41 PDT