Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 09, 2025 - 17:01 PDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Jun 08, 2025 - 23:54 PDT
Scheduled
The T-Mobile network in the United States is conducting a series of emergency maintenances from 09 June 2025 at 17:00 PDT until 12 June 2025 at 05:00 PDT. During the maintenance window, there could be intermittent delays delivering SMS and MMS to T-Mobile United States handsets when sending via long codes and short codes.
Note, the maintenance will be carried out on each of the following dates and times:
09 June 2025 at 17:00 PDT until 10 June 2025 at 05:00 PDT
10 June 2025 at 17:00 PDT until 11 June 2025 at 05:00 PDT
11 June 2025 at 17:00 PDT until 12 June 2025 at 05:00 PDT
We are aware of the short notice and are working with our Carrier Partners to provide earlier notification where possible.
Posted Jun 08, 2025 - 23:54 PDT
This scheduled maintenance affects: PROGRAMMABLE MESSAGING (MMS, SMS).