The incident has been resolved and MMS delivery from network subscribers on affected networks in the United States to a subset of Twilio Short Codes is operating normally.
Posted Jul 08, 2026 - 17:16 PDT
Update
We have observed a recovery in MMS delivery from network subscribers on multiple networks in the United States to a subset of Twilio Short Codes and are monitoring service stability. We will provide another update in 4 hours or as soon as more information becomes available.
Posted Jul 08, 2026 - 17:15 PDT
Update
We have observed a recovery in MMS delivery from network subscribers on multiple networks in the United States to a subset of Twilio Short Codes and are monitoring service stability. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Jul 08, 2026 - 15:14 PDT
Monitoring
We have observed a recovery in MMS delivery from network subscribers on multiple networks in the United States to a subset of Twilio Short Codes and are monitoring service stability. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Jul 08, 2026 - 15:02 PDT
Identified
Twilio customers may be experiencing MMS delivery delays from network subscribers to a subset of Twilio United States Short Codes. Our team is actively investigating this issue. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Jul 08, 2026 - 14:00 PDT
Investigating
Twilio customers may be experiencing MMS delivery delays from network subscribers to a subset of Twilio United States Short Codes. Our team is actively investigating this issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Jul 08, 2026 - 12:55 PDT
This incident affected: CARRIER NETWORK (MMS Short Code, North America).