Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Delays to Telenor Pakistan
      Incident Report for Twilio
      Resolved
      We are no longer experiencing delivery delays when sending to Telenor Pakistan. This incident has been resolved.
      Posted Sep 21, 2020 - 03:06 PDT
      Monitoring
      We are observing recovery in delivery delays when sending to Telenor in Pakistan. We will continue monitoring the service to ensure a full recovery. We will provide another update to confirm the fix.
      Posted Sep 21, 2020 - 02:52 PDT
      Update
      Our engineering team is still investigating this issue with our carrier partner. We will provide more information as soon as they become available.
      Posted Sep 21, 2020 - 01:54 PDT
      Investigating
      We are experiencing SMS delivery delays when sending messages to Telenor in Pakistan. Our engineers are working with our carrier partner to resolve the issue. We will provide another update once more information becomes available.
      Posted Sep 21, 2020 - 00:50 PDT
      This incident affected: CARRIER NETWORK (SMS, APAC).