Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Delays and Call Failures to Verizon Network in the US
      Incident Report for Twilio
      Resolved
      As per confirmation from Verizon Network, they have resolved the problems on their platform. We can also confirm stability in Twilio SMS and Voice services at this time. This incident has been resolved.
      Posted Sep 30, 2024 - 17:12 PDT
      Monitoring
      Verizon Network has confirmed recovery on their services. We continue to monitor the situation, with no major impact on Twilio's Services due to this particular issue. Our engineers are working with Verizon Network to follow up with a resolution for this issue. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Sep 30, 2024 - 15:13 PDT
      Update
      Verizon Network has confirmed recovery on their services. We continue to monitor the situation, with no major impact on Twilio's Services due to this particular issue. Our engineers are working with Verizon Network to follow up with a resolution for this issue. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Sep 30, 2024 - 14:58 PDT
      Update
      Verizon Network is still working in order to identify and resolve the situation. We can confirm that we are still not seeing major impact on Twilio's Services due to this particular issue. Our engineers are working with Verizon Network to follow up with a resolution for this issue. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Sep 30, 2024 - 12:59 PDT
      Investigating
      We have been informed that Verizon Network in the US is experiencing an outage on their system that can potentially impact our SMS and Voice Services. We can confirm that currently we have not identified a major impact for Twilio’s customers, although customers may experience issues with their overall Verizon messaging and voice services. Our engineers are working with Verizon to follow up the resolution of the issue. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted Sep 30, 2024 - 11:53 PDT
      This incident affected: CARRIER NETWORK (SMS Long Code, North America, SMS Short Code, North America, Voice, North America).