Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Delays in Twilio Billing Processing Causing Account Suspension for a Subset of Customers
Incident Report for Twilio
Resolved
The billing processing issue that caused delays in account balance reflection has been resolved and Billing is operating normally at this time.
Posted Nov 17, 2021 - 16:19 PST
Monitoring
We are observing recovery for the billing processing issues that caused delays in account balance reflection for a subset of customers. We will continue to monitor for system stability. We'll provide another update in 2 hours or as soon as more information becomes available.
Posted Nov 17, 2021 - 15:20 PST
Update
We continue to investigate the billing processing issues that are causing delays in account balance reflection and could result in account suspension for a subset of customers. Please reach out to Twilio Support if your account is suspended and our team will assist you immediately. We are actively working on resolving the issue and will provide another update in 16 hours or as soon as more information becomes available.
Posted Nov 17, 2021 - 14:10 PST
Update
We continue to investigate the billing processing issues that are causing delays in account balance reflection and could result in account suspension for a subset of customers. Please reach out to Twilio Support if your account is suspended and our team will assist you immediately. We are actively working on resolving the issue and will provide another update in 8 hours or as soon as more information becomes available.
Posted Nov 17, 2021 - 06:10 PST
Update
We continue to investigate the billing processing issues that are causing delays in account balance reflection and could result in account suspension for a subset of customers. Please reach out to Twilio Support if your account is suspended and our team will assist you immediately. We are actively working on resolving the issue and will provide another update in 8 hours or as soon as more information becomes available.
Posted Nov 16, 2021 - 22:11 PST
Update
We continue to investigate the billing processing issues that are causing delays in account balance reflection and could result in account suspension for a subset of customers. Please reach out to Twilio Support if your account is suspended and our team will assist you immediately. We are actively working on resolving the issue and will provide another update in 4 hours or as soon as more information becomes available.
Posted Nov 16, 2021 - 18:13 PST
Update
We continue to investigate the billing processing issues that are causing delays in account balance reflection and could result in account suspension for a subset of customers. Please reach out to Twilio Support if your account is suspended and our team will assist you immediately. We are actively working on resolving the issue and will provide another update in 2 hours or as soon as more information becomes available.
Posted Nov 16, 2021 - 16:10 PST
Update
We are investigating an issue with Billing Processing and Balance Update Reflection Causing Account Suspension for a Subset of Customers. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Nov 16, 2021 - 15:14 PST
Investigating
We've become aware of a potential issue with Account Balance Delays. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Nov 16, 2021 - 14:49 PST
This incident affected: TWILIO PLATFORM (Billing).