Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Message and message delivery receipt delays to T-Mobile handsets
Incident Report for Twilio
Resolved
Message and message delivery receipt delays to T-Mobile handsets in the US have recovered. All systems are now fully operational.
Posted 9 months ago. May 25, 2018 - 13:18 PDT
Monitoring
Message and message delivery receipt delays to T-Mobile handsets in the US have recovered. We will continue to monitor. All systems are now fully operational
Posted 9 months ago. May 25, 2018 - 13:04 PDT
Investigating
We are currently experiencing message and message delivery receipt delays to T-Mobile handsets in the US. Our engineers are working with our carrier partner to restore service. We will provide an update as quickly as possible.
Posted 9 months ago. May 25, 2018 - 12:48 PDT
This incident affected: CARRIER NETWORK (SMS Short Code, North America) and PROGRAMMABLE MESSAGING (SMS).