Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 04, 2026 - 13:02 PDT
Scheduled
Our Voice carrier partner in Ghana, Rwanda, South Africa and Nigeria is conducting a series of planned maintenances from 04 June 2026 at 13:00 PDT until 05 June 2026 at 20:00 PDT. During the maintenance window, there could be intermittent call disconnects or call failures from and to Twilio Ghana, Rwanda, South Africa and Nigeria mobile phone numbers.
Note, the maintenance will be carried out on each of the following dates and times:
04 June 2026 at 13:00 PDT until 04 June 2026 at 20:00 PDT
05 June 2026 at 13:00 PDT until 05 June 2026 at 20:00 PDT
We are aware of the short notice and are working with our Carrier Partners to provide earlier notification where possible.
Posted Jun 03, 2026 - 17:00 PDT
This scheduled maintenance affects: CARRIER NETWORK (Voice, Middle East & Africa).