Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Failures on T-Mobile
      Incident Report for Twilio
      Resolved
      We are no longer experiencing SMS delivery failures when sending messages to T-Mobile. This incident has been resolved.
      Posted May 04, 2022 - 10:12 PDT
      Monitoring
      We are observing successful SMS delivery recovery when sending messages to T-Mobile for the last 30 minutes. We will continue to monitor to ensure full service recovery. We expect to provide another update in 2 hours or as soon as more information becomes available.
      Posted May 04, 2022 - 08:14 PDT
      Update
      We are experiencing SMS delivery failures when sending messages to T-Mobile. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted May 04, 2022 - 07:54 PDT
      Investigating
      Our monitoring systems have detected a potential issue with Messages not delivering to T-Mobile users. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted May 04, 2022 - 07:19 PDT
      This incident affected: CARRIER NETWORK (SMS Long Code, North America).