Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Message status callbacks delays
Incident Report for Twilio
Resolved
All delays in message status callback events have returned to normal levels. All services are operating normally
Posted 21 days ago. Sep 03, 2019 - 11:31 PDT
Monitoring
Our engineering team has addressed the issue and we are observing delays in message status callback events starting to return back to normal levels, we will post another update when service has been fully restored.
Posted 21 days ago. Sep 03, 2019 - 11:22 PDT
Identified
We have identified an issue causing delays in message status callback events for some SMS messages. The engineering team is currently working on resolving the issue. This issue is not impacting message delivery. We will provide an update as soon as we have additional information.
Posted 21 days ago. Sep 03, 2019 - 10:43 PDT
This incident affected: CARRIER NETWORK (SMS Delivery Notifications & Status Callbacks).