Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Carriers around the world are experiencing capacity issues because of increased demand on their networks due to COVID-19. This may result in voice quality issues, busy signals, or other errors on your phone calls. Twilio continues to monitor the health of the global carrier networks and we are publishing the most up-to-date information on our Worldwide Telephony Network Congestion page.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Voice Inbound call Congestion - Australia
Incident Report for Twilio
Resolved
For more information on worldwide telephony network congestion please see the following page: https://support.twilio.com/hc/en-us/articles/360045682893-Worldwide-Telephony-Network-Congestion-Update
Posted Mar 26, 2020 - 15:01 PDT
Update
We still see inbound calls to Australian Twilio numbers fail due to traffic increases. Callers may hear a recorded announcement "The service to the telecommunication network you are calling is congested, please try again later." Our engineers are working with our carrier partners to increase the capacity to resolve the issue. We will provide an update as soon as we have additional information.
Posted Mar 24, 2020 - 22:42 PDT
Identified
We see Inbound calls to Australian Twilio numbers fail due to traffic increase. Callers may hear a recorded announcement “The service to the telecommunication network you are calling is congested, please try again later”. Our engineers are working with our carrier partners to increase the capacity to resolve the issue. We will provide an update as soon as we have additional information.
Posted Mar 23, 2020 - 19:20 PDT
Monitoring
We are observing recovery in voice traffic inbound to Australian Twilio numbers. We will continue to monitor this situation and will provide an update as soon as more information becomes available.
Posted Mar 22, 2020 - 23:50 PDT
Update
Our engineering team and carrier partner are continuing to work on a resolution. We will provide an update as soon as we have additional information.
Posted Mar 22, 2020 - 20:57 PDT
Identified
We see Inbound calls to Australian Twilio numbers fail due to an unexpected traffic increase. Callers may hear a recorded announcement “The service to the telecommunication network you are calling is congested, please try again later”. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
Posted Mar 22, 2020 - 19:06 PDT
This incident affected: CARRIER NETWORK (Voice, APAC).