Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
MMS Delivery Delays When Sending to the US From a Subset of Twilio Short Codes
Incident Report for Twilio
Resolved
We have confirmed recovery of delivery reports for MMS to AT&T. This incident is now resolved.
Posted Oct 11, 2020 - 13:30 PDT
Update
We continue to see recovery for delivery of MMS messages to all carriers however delivery reports are missing for MMS to AT&T. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update as more information becomes available.
Posted Oct 10, 2020 - 22:27 PDT
Update
We continue to see recovery for delivery of MMS messages to all carriers however delivery reports are missing for MMS to AT&T. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 16 hours or as soon as more information becomes available.
Posted Oct 10, 2020 - 05:19 PDT
Update
We continue to see recovery for delivery of MMS messages to all carriers however delivery reports are missing for MMS to AT&T. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 8 hours or as soon as more information becomes available.
Posted Oct 09, 2020 - 21:20 PDT
Identified
We are still seeing recovery for delivery of MMS messages to all carriers however delivery reports are missing for MMS to AT&T. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 4 hours or as soon as more information becomes available.
Posted Oct 09, 2020 - 17:20 PDT
Monitoring
We are now seeing recovery for MMS messages to all carriers in the last 5 minutes. We will continue to monitor to ensure full service recovery. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Oct 09, 2020 - 16:27 PDT
Update
We are still experiencing MMS delivery delays for the queued MMS to AT&T. Our engineers are continuing to work with our carrier partner to resolve the issue. We expect to provide another update in 4 hour or as soon as more information becomes available.
Posted Oct 09, 2020 - 14:15 PDT
Identified
We are now seeing recovery for MMS messages to all carriers except AT&T. For messages to AT&T, our engineers made a change to convert MMS to Picture Message. Any AT&T messages prior to the change are queued and will be delivered with delay, but new ones will be delivered as a Picture Message without delay. Our engineers are continuing to work with our carrier partner to resolve the issue. We expect to provide another update in 2 hour or as soon as more information becomes available.
Posted Oct 09, 2020 - 12:02 PDT
Update
We are experiencing MMS delivery delays from a small subset of US Shortcodes to US carriers. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Oct 09, 2020 - 11:02 PDT
Investigating
Our monitoring systems have detected a potential issue. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Oct 09, 2020 - 10:58 PDT
This incident affected: CARRIER NETWORK (MMS Short Code, North America).