Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Inbound Call Failures to (a Subset of) Twilio UK Phone Numbers
Incident Report for Twilio
Resolved
We can confirm recovery for inbound calls to Twilio UK phone numbers. This incident has been resolved.
Posted Jun 03, 2021 - 05:08 PDT
Update
We are still monitoring the recovery for inbound calls to Twilio UK phone numbers. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Jun 03, 2021 - 05:02 PDT
Monitoring
We have started seeing recovery for inbound calls to Twilio UK phone numbers for the last 60 minutes. We will continue to monitor to ensure a full recovery. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Jun 03, 2021 - 03:03 PDT
Investigating
We are observing a subset of call failures to Twilio UK phone numbers. We are currently working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Jun 03, 2021 - 02:10 PDT
This incident affected: PROGRAMMABLE VOICE (PSTN).