Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
API Timeouts from Programmable Messaging and Verify APIs
Incident Report for Twilio
Resolved
The issue causing API timeouts when sending messages through the Verify API has been resolved, and the service is functioning normally at this time.
Posted Jul 12, 2021 - 11:18 PDT
Monitoring
The incident causing API timeouts when sending messages through the Verify API has been identified to be related to an external network issue. The external network provider has implemented a fix, and we are now observing recovery. Our engineers will continue monitoring to ensure full service recover. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Jul 12, 2021 - 09:29 PDT
Update
We are still observing API timeouts when sending messages through the Verify API but messages sent through the Programmable Messaging API are no longer affected. Our engineers continue working to resolve the issue. We expect to provide another update in 4 hours or as soon as more information becomes available.
Posted Jul 12, 2021 - 08:30 PDT
Investigating
The attempted remediation did not resolve the issue, and we continue to observe API timeouts when trying to send messages through Programmable Messaging and Verify APIs. Our engineers continue working to resolve the issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Jul 12, 2021 - 06:39 PDT
Monitoring
A fix has been implemented and we are monitoring the results. We expect to provide another update in 2 hours, or as soon as more information becomes available.
Posted Jul 12, 2021 - 04:40 PDT
Update
We are noticing API timeouts when trying to send messages through Programmable Messaging and Verify APIs. We are currently working to resolve the issue. We expect to provide another update in 1 hour, or as soon as more information becomes available.
Posted Jul 12, 2021 - 04:39 PDT
Investigating
We've become aware of a potential issue with SMS . Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Jul 12, 2021 - 04:04 PDT
This incident affected: ACCOUNT SECURITY (Verify) and PROGRAMMABLE MESSAGING (SMS).