Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Inconsistent Bill Amount Reporting with Programmable Wireless Usage APIs
Incident Report for Twilio
Resolved
The issue with inconsistent bill amount reporting with Programmable Wireless Usage APIs has been resolved and Programmable Wireless is operating normally at this time. This incident has been resolved.
Posted Nov 23, 2021 - 23:39 PST
Monitoring
The issue with inconsistent bill amount reporting with Programmable Wireless Usage APIs is now operating normally. We will continue to monitor for system stability. We’ll provide another update in 30 minutes or as soon as more information becomes available.
Posted Nov 23, 2021 - 23:06 PST
Update
Customers querying Usage records via the Usage APIs may still experience inconsistent results with the billed amount values returned. This is only affecting the reported period for the month of November. Our engineers are currently working on fixing reported data up to the 7th of November. We will provide another update in 24 hours or as soon as more information becomes available.
Posted Nov 23, 2021 - 13:27 PST
Update
Customers querying Usage records via the Usage APIs may still experience inconsistent results with the billed amount values returned. This is only affecting the reported period for the month of November. Our engineers are currently working on fixing reported data up to the 7th of November. We will provide another update in 16 hours or as soon as more information becomes available.
Posted Nov 22, 2021 - 21:20 PST
Identified
The issue with inconsistent bill amount reporting with Programmable Wireless Usage APIs has been identified. Customers querying Usage records via the Usage APIs may still experience inconsistent results with the billed amount values returned. This is only affecting the reported period for the month of November. Our engineers are currently working on fixing reported data up to the 7th of November. We will provide another update in 8 hours or as soon as more information becomes available.
Posted Nov 22, 2021 - 13:20 PST
Update
We are still experiencing inconsistent bill amount reporting with Programmable Wireless Usage APIs. Customers querying Usage records via the Usage APIs may experience inconsistent results with the billed amount values returned. This is only affecting the reported period for the month of November. We will provide another update in 4 hours or as soon as more information becomes available.
Posted Nov 22, 2021 - 09:30 PST
Update
We are still experiencing inconsistent bill amount reporting with Programmable Wireless Usage APIs. Customers querying Usage records via the Usage APIs may experience inconsistent results with the billed amount values returned. This is only affecting the reported period for the month of November. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Nov 22, 2021 - 07:43 PST
Investigating
We are experiencing inconsistent bill amount reporting with Programmable Wireless Usage APIs. Customers querying Usage records via the Usage APIs may experience inconsistent results with the billed amount values returned. This is only affecting the reported period for the month of November. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Nov 22, 2021 - 06:45 PST
This incident affected: INTERNET OF THINGS (Programmable Wireless).