Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      T-Mobile network failures in North America impacting Twilio Voice, Messaging and Wireless products
      Incident Report for Twilio
      Resolved
      We are no longer experiencing problems with MMS delivery, outbound and inbound calls, and Programmable Wireless services via T-Mobile.
      Posted Jun 16, 2020 - 00:13 PDT
      Monitoring
      We are seeing a recovery across MMS delivery, outbound and inbound calls, and Programmable Wireless services via T-Mobile. We will provide further updates as more information becomes available.
      Posted Jun 15, 2020 - 21:19 PDT
      Update
      We are continuing to work with our carrier partner to resolve the issue with SMS and MMS delivery delays, outbound and inbound calls, and Programmable Wireless via T-Mobile. We will provide further updates as more information becomes available.
      Posted Jun 15, 2020 - 21:12 PDT
      Update
      We are continuing to work with our carrier partner to resolve the issue with SMS and MMS delivery delays, outbound and inbound calls, and Programmable Wireless via T-Mobile. We will provide further updates as more information becomes available.
      Posted Jun 15, 2020 - 17:29 PDT
      Update
      We are continuing to work with our carrier partner to resolve the issue with SMS and MMS delivery delays, outbound and inbound calls, and Programmable Wireless via T-Mobile. We will provide further updates as more information becomes available.
      Posted Jun 15, 2020 - 15:35 PDT
      Update
      We are continuing to work with our carrier partner to resolve the issue with SMS and MMS delivery delays, outbound and inbound calls, and Programmable Wireless via T-Mobile. We will provide further updates as more information becomes available.
      Posted Jun 15, 2020 - 14:31 PDT
      Investigating
      We are experiencing SMS and MMS delivery delays, as well as outbound and inbound calls via T-Mobile. This is for Short Code, Toll-Free, and Long Codes. Programmable Wireless data, SMS, and voice may be impacted, as well as SIP trunking, and PTSN. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
      Posted Jun 15, 2020 - 13:58 PDT
      This incident affected: ELASTIC SIP TRUNKING (Origination), PROGRAMMABLE VOICE (PSTN), and CARRIER NETWORK (SMS Long Code, North America, MMS Long Code, North America, SMS Short Code, North America, MMS Short Code, North America, SMS Toll-Free, North America, Voice, North America).