Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Super SIM Connectivity Issues With 2G/3G Networks
Incident Report for Twilio
Resolved
Super SIM devices experiencing connectivity issues with 2G/3G networks has been resolved and Super SIM product is operating normally at this time after a solution has been rolled out and our team is not observing any issues anymore. This incident is resolved.
Posted Jul 13, 2021 - 01:30 PDT
Monitoring
Our engineering team have investigated an issue with Super SIM devices experiencing connectivity issues with 2G/3G networks. Devices with already established data sessions were not affected, however may have experienced delays when trying to re-connect to the network. We have seen these devices connecting successfully later on, we will be monitoring to ensure full recovery, we will provide an update in 2 hours or as soon as more information becomes available.
Posted Jul 13, 2021 - 00:58 PDT
Investigating
We've become aware of a potential issue with Super SIM devices may experience connectivity issues with 2G networks. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Jul 13, 2021 - 00:30 PDT
This incident affected: INTERNET OF THINGS (Super SIM).