The issue with verifying phone numbers with Twilio via voice call has been resolved and verifying phone numbers is operating normally at this time.
Posted Sep 25, 2025 - 14:39 PDT
Update
Verifying phone numbers via Voice calls is now operating normally. We will continue to monitor for system stability. We'll provide another update in 2 hours or as soon as more information becomes available.
Posted Sep 25, 2025 - 12:17 PDT
Monitoring
Verifying phone numbers via Voice calls is now operating normally. We will continue to monitor for system stability. We'll provide another update in 2 hours or as soon as more information becomes available.
Posted Sep 25, 2025 - 10:17 PDT
Investigating
We are investigating a service interruption while verifying phone numbers with Twilio via Voice calls. As a workaround, you can still move forward via SMS or by contacting support for manual verification. Our engineers are working to identify a fix for this issue. We expect to provide another update in 1 hour or as soon as more information becomes available.