Our engineers have monitored the fix and confirmed the issue with elevated timeouts and latency in Porting Dbs has been resolved. All services are now operating normally at this time.
Posted Dec 15, 2025 - 22:21 PST
Update
We are continuing to observe recovery in elevated timeouts and latency in Porting Dbs. Our engineers have implemented a fix and are monitoring system performance. We will provide another update in 4 hours or as soon as more information becomes available.
Posted Dec 15, 2025 - 21:19 PST
Update
We are continuing to observe recovery in Elevated Timeouts and Latency in Porting Dbs. Our engineers have implemented a fix and are monitoring system performance. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Dec 15, 2025 - 19:20 PST
Update
We are observing recovery in Elevated Timeouts and Latency in Porting Dbs. Our engineers have implemented a fix and are monitoring system performance. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Dec 15, 2025 - 17:29 PST
Monitoring
We are observing recovery in Elevated Timeouts and Latency in Porting Dbs. Our engineers have implemented a fix and are monitoring system performance. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Dec 15, 2025 - 15:46 PST
Update
We are still investigating an issue with porting US numbers to Twilio. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Dec 15, 2025 - 14:31 PST
Update
We are still investigating an issue with porting US numbers to Twilio. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Dec 15, 2025 - 13:38 PST
Investigating
We are currently investigating an issue with porting US numbers to Twilio. We will provide another update in 1 hour or as soon as more information becomes available.