Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
On Call Engineers are Investigating
Incident Report for Twilio
Resolved
We have determined there is no customer impact for the DNS related issue that could have caused issues reaching our API endpoints. All systems are operational.
Posted Jul 27, 2020 - 14:33 PDT
Update
We are continuing to investigate a potential DNS related issue that may cause issues reaching our API endpoints. At this time we have not identified any impact to our customers. We will update as soon as we have more information.
Posted Jul 27, 2020 - 13:26 PDT
Update
We are investigating a potential DNS related issue that may cause issues reaching our API endpoints. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Jul 27, 2020 - 12:14 PDT
Update
Our monitoring systems have detected a potential DNS related issues that may cause issues reaching our API endpoints
Posted Jul 27, 2020 - 12:06 PDT
Investigating
Our monitoring systems have detected a potential issue. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Jul 27, 2020 - 11:51 PDT
This incident affected: TWILIO PLATFORM (REST API).