Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Delays and Failures over T-Mobile, Metro PCS and Sprint Networks in the US to a Subset of Twilio Short Codes
      Incident Report for Twilio
      Resolved
      We are no longer experiencing SMS delivery delays and failures over US T-Mobile, Metro PCS, and Sprint to a subset of Twilio short codes. This incident has been resolved.
      Posted Dec 02, 2022 - 14:50 PST
      Monitoring
      We are observing recovery in SMS delivery delays and failures over US T-Mobile, Metro PCS, and Sprint to a subset of Twilio short codes. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Dec 02, 2022 - 12:57 PST
      Update
      We are continuing to work with our carrier partner to resolve SMS delivery delays and failures over US T-Mobile, Metro PCS, and Sprint to a subset of Twilio short codes. We expect to provide another update in 2 hours or as soon as more information becomes available.
      Posted Dec 02, 2022 - 10:59 PST
      Investigating
      We are experiencing SMS delivery delays and failures over US T-Mobile, Metro PCS, and Sprint to a subset of Twilio short codes. We are working with our carrier partners to resolve this issue. We expect to provide another update in X hours or as soon as more information becomes available.
      Posted Dec 02, 2022 - 09:54 PST
      This incident affected: CARRIER NETWORK (SMS Short Code, North America).