Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Interconnect
Incident Report for Twilio
Resolved
Service is restored.
Posted about 1 year ago. Mar 02, 2018 - 09:45 PST
Monitoring
Services are recovered. We are continuing to actively monitor.
Posted about 1 year ago. Mar 02, 2018 - 09:39 PST
Identified
We have identified the issue.
Posted about 1 year ago. Mar 02, 2018 - 09:13 PST
Update
We are continuing to experience failures in US1. Customers with US2 connectivity should send traffic here
Posted about 1 year ago. Mar 02, 2018 - 08:41 PST
Investigating
We are experiencing call failures in US1 Interconnect site. On-call team is responding
Posted about 1 year ago. Mar 02, 2018 - 07:11 PST
This incident affected: INTERCONNECT.