Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Inbound calls failing intermittently to a subset of Twilio Belgium numbers.
      Incident Report for Twilio
      Resolved
      This incident has been resolved.
      Posted Apr 03, 2020 - 13:08 PDT
      Monitoring
      A fix has been implemented and we are monitoring the results.
      Posted Apr 03, 2020 - 12:50 PDT
      Update
      We are continuing to investigate failures of inbound calls to a subset of Twilio numbers in Belgium.
      Posted Apr 03, 2020 - 12:28 PDT
      Update
      We are are continuing to investigate failures of inbound calls to a subset of Twilio numbers in Belgium.
      Posted Apr 03, 2020 - 10:24 PDT
      Update
      We have been experiencing Inbound calls to a subset of Twilio Belgium Numbers failing intermittently. Our engineering team is actively investigating the issue with our carrier partners. We will update as soon as we have more information.
      Posted Apr 03, 2020 - 08:32 PDT
      Investigating
      We have been experiencing Inbound calls to a subset of Twilio Belgium Numbers failing intermittently. Our engineering team is actively investigating the issue with our carrier partners. We will update as soon as we have more information.
      Posted Apr 03, 2020 - 08:07 PDT
      This incident affected: PROGRAMMABLE VOICE (PSTN).