Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Non-Us Trial Accounts Are Not Able to Provision Phone Numbers
      Incident Report for Twilio
      Resolved
      We have fully investigated the provision phone numbers issue with a subset of non-Us trial accounts triggered by our automated alert, and it was determined that there is no noticeable customer impact. All systems are operational.
      Posted May 09, 2022 - 10:26 PDT
      Investigating
      We've become aware of a potential issue with a subset of non-Us trial accounts are not able to provision phone numbers. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted May 09, 2022 - 09:58 PDT