Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Downloading mp3 Recordings Fail if the Download Takes Over 30 Seconds
Incident Report for Twilio
Resolved
We are no longer seeing the issue causing mp3 recording downloads to fail if the download takes over 30 seconds to process. This incident has been resolved.
Posted Jan 12, 2021 - 09:14 PST
Update
Engineering teams have put in a fix to address the issue causing mp3 recording downloads to fail if the download takes over 30 seconds to process. We are seeing recovery and are continuing to monitor for service performance. We will provide another update in 60 minutes or sooner once more information becomes available.
Posted Jan 12, 2021 - 08:24 PST
Monitoring
Engineering teams have put in a fix to address the issue causing mp3 recording downloads to fail if the download takes over 30 seconds to process. We are seeing recovery and are continuing to monitor for service performance. We will provide another update in 30 minutes or sooner once more information becomes available.
Posted Jan 12, 2021 - 07:54 PST
Update
We are continuing to investigate mp3 recording downloads failing if the download takes over 30 seconds to process. Our engineering team is actively investigating. We expect to provide another update in 60 minutes or as soon as more information becomes available.
Posted Jan 12, 2021 - 07:31 PST
Update
We have added Flex Insights as a degraded component, affected by this incident
Posted Jan 12, 2021 - 07:04 PST
Update
We have identified a problem where mp3 recording downloads fail if the download takes over 30 seconds to process. Our engineering team has been alerted and is actively investigating. We expect to provide another update in 30 minutes or as soon as more information becomes available.
Posted Jan 12, 2021 - 07:02 PST
Investigating
Our monitoring systems have detected a potential issue with recording downloads. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Jan 12, 2021 - 06:42 PST
This incident affected: FLEX (Flex Insights) and PROGRAMMABLE VOICE (Recording).