Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Zipwhip Gateway
      Issues related to Zipwhip's Services
        Scheduled maintenance
        System Metrics

        Account Upgrade Attempts Returning Error Messages

        Incident Report for Twilio

        Resolved

        The issue causing some customers to be unable to upgrade their accounts has been resolved.
        Posted Jan 21, 2026 - 13:13 PST

        Monitoring

        The issue causing some customers to be unable to upgrade their accounts has been mitigated. Customers should now be able to upgrade their accounts without issue. We are continuing to carefully monitor recovery to ensure recovery is sustained. We expect to provide another update in 2 hours or as soon as more information becomes available.
        Posted Jan 21, 2026 - 12:40 PST

        Update

        Some customers are currently experiencing error messages when attempting to upgrade their accounts in Console. Affected users may see error messages alerting them to wait up to 60 seconds before retrying. As a workaround, customers should attempt to upgrade via https://console.twilio.com/account/upgrade. Our team is actively investigating the issue and working to restore normal functionality. We will provide an update in 2 hours or as soon as more information becomes available.
        Posted Jan 21, 2026 - 11:32 PST

        Investigating

        Customers are currently experiencing error messages when attempting to upgrade their accounts in Console. Affected users may see error messages alerting them to wait up to 60 seconds before retrying. Our team is actively investigating the issue and working to restore normal functionality. We will provide an update in 1 hour or as soon as more information becomes available.
        Posted Jan 21, 2026 - 10:36 PST
        This incident affected: DEVELOPER TOOLS (Console).