Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Outbound Delivery Delays to Bangladesh Banglalink Digital
      Incident Report for Twilio
      Resolved
      We are no longer experiencing SMS delivery delays when sending to Bangladesh Banglalink. This incident has been resolved.
      Posted Jun 16, 2020 - 01:12 PDT
      Monitoring
      We are no longer observing SMS delivery delays to Banglalink Digital in Bangladesh. We will continue to monitor to ensure a full recovery.
      Posted Jun 16, 2020 - 00:26 PDT
      Update
      We are continuing to work with our carrier partner to resolve the issue. We will provide further updates as more information becomes available.
      Posted Jun 15, 2020 - 21:13 PDT
      Update
      We are continuing to work with our carrier partner to resolve the issue. We will provide further updates as more information becomes available.
      Posted Jun 15, 2020 - 17:28 PDT
      Update
      We are continuing to work with our carrier partner to resolve the issue. We will provide further updates as more information becomes available.
      Posted Jun 15, 2020 - 15:26 PDT
      Investigating
      We are experiencing SMS delivery delays when sending messages to Banglalink Digital. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
      Posted Jun 15, 2020 - 14:17 PDT
      This incident affected: CARRIER NETWORK (SMS, APAC).