Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
MMS Delivery Delays to AT&T and Verizon US from a Subset of Shortcodes
Incident Report for Twilio
Resolved
We are no longer experiencing delivery report delays when sending to AT&T US from a subset of Shortcodes. This incident has been resolved.
Posted Jan 03, 2021 - 06:37 PST
Monitoring
We are observing recovery in delivery report delays when sending to AT&T US from a subset of Shortcodes. We will continue monitoring the service to ensure a full recovery. We will provide another update in [X minutes] or as soon as more information becomes available.
Posted Jan 03, 2021 - 06:05 PST
Update
We are continuing to investigate MMS delivery delays to AT&T and Verizon US from a Subset of Short codes. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 24 hours or as soon as more information becomes available.
Posted Jan 02, 2021 - 15:16 PST
Update
We are still experiencing MMS delivery delays to AT&T and Verizon US from a Subset of Shortcodes. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 16 hours or as soon as more information becomes available.
Posted Jan 01, 2021 - 23:11 PST
Update
We are still experiencing MMS delivery delays to AT&T and Verizon US from a Subset of Shortcodes. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 8 hours or as soon as more information becomes available.
Posted Jan 01, 2021 - 15:10 PST
Update
We are still experiencing MMS delivery delays to AT&T and Verizon US from a Subset of Shortcodes. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 4 hours or as soon as more information becomes available.
Posted Jan 01, 2021 - 11:14 PST
Update
We are still experiencing MMS delivery delays to AT&T and also Verizon US from a Subset of Shortcodes. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Jan 01, 2021 - 09:21 PST
Update
We are still experiencing MMS delivery delays to AT&T US from a Subset of Shortcodes. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Jan 01, 2021 - 09:14 PST
Investigating
We are experiencing MMS delivery delays to AT&T US from a subset of Shortcodes. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Jan 01, 2021 - 08:14 PST
This incident affected: CARRIER NETWORK (MMS Short Code, North America, SMS Delivery Notifications & Status Callbacks).