Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Carriers around the world are experiencing capacity issues because of increased demand on their networks due to COVID-19. This may result in voice quality issues, busy signals, or other errors on your phone calls. Twilio continues to monitor the health of the global carrier networks and we are publishing the most up-to-date information on our Worldwide Telephony Network Congestion page.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Not delivered to Banglalink Digital network in Bangladesh.
Incident Report for Twilio
Resolved
The issue was resolved and messages are delivered normally now to Banglalink Digital network in Bangladesh.
Posted Jan 21, 2020 - 07:41 PST
Investigating
We are experiencing SMS non-delivery to Banglalink Digital network in Bangladesh. Our engineers are working with the underlined carrier to fix this issue. We will provide more information in the next hour.
Posted Jan 21, 2020 - 06:49 PST
This incident affected: CARRIER NETWORK (SMS, APAC).