Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Zipwhip Gateway
      Issues related to Zipwhip's Services
        Scheduled maintenance
        System Metrics

        Issues When Attempting to Update Whatsapp Profiles via API and Console for a Subset of Users

        Incident Report for Twilio

        Resolved

        WhatsApp Business Profile management performance issues have been resolved and the WhatsApp Messaging Channel is operating normally at this time.
        Posted Mar 27, 2026 - 07:19 PDT

        Monitoring

        WhatsApp Business Profile management is now operating normally and we are no longer seeing performance issues. We will continue to monitor for system stability. We'll provide another update in 30 minutes or as soon as more information becomes available.
        Posted Mar 27, 2026 - 06:49 PDT

        Update

        Performance issues are still reported with WhatsApp Business Profile management. This is affecting a subset of users attempting to update profiles via the API and Twilio Console. Engineers are investigating. We will provide an update in 16 hours or as soon as more information becomes available.
        Posted Mar 27, 2026 - 00:45 PDT

        Update

        Performance issues are still reported with WhatsApp Business Profile management. This is affecting a subset of users attempting to update profiles via the API and Twilio Console. Engineers are investigating. We will provide an update in 8 hours or as soon as more information becomes available.
        Posted Mar 26, 2026 - 16:57 PDT

        Update

        Performance issues are still reported with WhatsApp Business Profile management. This is affecting a subset of users attempting to update profiles via the API and Twilio Console. Engineers are investigating. We will provide an update in 4 hours or as soon as more information becomes available.
        Posted Mar 26, 2026 - 13:32 PDT

        Update

        Performance issues are still reported with WhatsApp Business Profile management. This is affecting a subset of users attempting to update profiles via the API and Twilio Console. Engineers are investigating. We will provide an update in 2 hours or as soon as more information becomes available.
        Posted Mar 26, 2026 - 11:59 PDT

        Investigating

        Performance issues have been reported with WhatsApp Business Profile management. This is affecting a subset of users attempting to update profiles via the API and Twilio Console. Engineers are investigating. We will provide an update in 1 hour or as soon as more information becomes available.
        Posted Mar 26, 2026 - 11:11 PDT
        This incident affected: PROGRAMMABLE MESSAGING (Messaging Channels).