Our engineers have confirmed full recovery for the issue causing errors and message delays on the WhatsApp channel for Verify. This incident is resolved.
Posted Mar 25, 2026 - 14:06 PDT
Monitoring
Our engineers have begun to see recovery for the issue causing errors and message delays on the WhatsApp channel for Verify. We will continue to monitor to ensure a full recovery. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Mar 25, 2026 - 13:08 PDT
Update
Our engineers have identified an issue causing errors and message delays on the WhatsApp channel for Verify. We are working with the provider on a resolution and expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Mar 25, 2026 - 11:16 PDT
Identified
Our engineers have identified an issue causing errors and message delays on the WhatsApp channel for Verify. We are working with the provider on a resolution and expect to provide another update in one hour or as soon as more information becomes available.
Posted Mar 25, 2026 - 10:06 PDT
This incident affected: PROGRAMMABLE MESSAGING (WhatsApp Messaging).