Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Delays to XL Axiata Indonesia
Incident Report for Twilio
Resolved
We are no longer experiencing delivery delays when sending SMS to XL Axiata Indonesia. This incident has been resolved.
Posted Jul 01, 2020 - 00:10 PDT
Monitoring
SMS are now getting delivered properly to XL Axiata Indonesia. Our engineers are continuing to monitor the situation and will provide another update as soon as we confirm the issue is completely resolved.
Posted Jun 30, 2020 - 23:32 PDT
Update
We are continuing to work with our carrier partner to resolve the issue. We will provide additional updates as soon as possible.
Posted Jun 30, 2020 - 23:18 PDT
Update
We are continuing to work with our carrier partner to resolve the issue. We will provide additional updates as soon as possible.
Posted Jun 30, 2020 - 19:17 PDT
Update
We are continuing to work with our carrier partner to resolve the issue. We will provide additional updates as soon as possible.
Posted Jun 30, 2020 - 17:22 PDT
Investigating
We are observing SMS delivery delays to the XL Axiata network in Indonesia. Our engineers are working with our carrier partner to resolve this issue.
Posted Jun 30, 2020 - 16:28 PDT
This incident affected: CARRIER NETWORK (SMS, APAC).