Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Real-time agent and task data issue in Flex
Incident Report for Twilio
Resolved
This incident of real-time agent and task data issue in Flex has been fully resolved.
Posted Oct 11, 2020 - 04:13 PDT
Update
We are continuing to monitor the system to ensure full service recovery. We will provide further updates as soon as more information becomes available.
Posted Oct 11, 2020 - 01:17 PDT
Monitoring
Service is restored to the Teams View and task transfer. Agents will display in the Agent Directory and Teams View once they update their activity status or interact with tasks. Not all agents will be available immediately. We will continue to monitor to ensure full service recovery. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Oct 11, 2020 - 00:04 PDT
Update
Twilio Engineering is still working towards service restoration. The initial planned approach with 10-minute service disruption is taking longer then expected due to data re-indexing. The Flex Teams View will be unable to load data for your agents and tasks, and your agents will be unable to transfer tasks to other agents and queues. We will provide an update in 1 hour or as soon as more information becomes available.
Posted Oct 10, 2020 - 23:33 PDT
Update
Twilio Engineering is still working towards service restoration and will provide an update in 1 hour or as soon as more information becomes available.
Posted Oct 10, 2020 - 22:17 PDT
Update
Agents are currently unable to transfer tasks, and the Teams View will not display data for your agents and tasks. Twilio Engineering is moving the maintenance window to begin service restoration. We will provide an update in 30 minutes or as soon as more information becomes available.
Posted Oct 10, 2020 - 21:33 PDT
Update
We have a scheduled maintenance and there will be a temporary service disruption at 06:00 UTC. At that time, the Flex Teams View will be unable to load data for your agents and tasks, and your agents will be unable to transfer tasks to other agents and queues. We are expecting the service disruption to last approximately 10 minutes, until 06:10 UTC.
Posted Oct 10, 2020 - 18:45 PDT
Identified
To address the Teams View real-time issue, we are scheduling temporary service disruption at 06:00 UTC. At that time, the Flex Teams View will be unable to load data for your agents and tasks, and your agents will be unable to transfer tasks to other agents and queues. We are expecting the service disruption to last approximately 10 minutes, until 06:10 UTC.
Posted Oct 10, 2020 - 14:49 PDT
Update
We are continuing to investigate the issues where agent and task data on the Flex Teams View is not updating in real-time. We expect to provide another update in 4 hours or as soon as more information becomes available.
Posted Oct 10, 2020 - 12:17 PDT
Update
We are investigating an issue where agent and task data on the Flex Teams View is not updating in real-time. We expect to provide another update in 2 hours.
Posted Oct 10, 2020 - 10:31 PDT
Update
Agent and task data on the Flex Teams View will not update in real-time. Data will be refreshed when you set or reset the filters on the Teams View, or if you refresh the page in Flex.
Posted Oct 10, 2020 - 09:21 PDT
Update
We are continuing to investigate this issue.
Posted Oct 10, 2020 - 09:01 PDT
Investigating
Our monitoring systems have detected a potential issue with Sync Insights. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Oct 10, 2020 - 08:58 PDT
This incident affected: FLEX (Flex Application Platform).