Status
Welcome to the Twilio status page. Here you will find real-time information about status of our services.
Delivery delay inbound messages to Twilio Mexico numbers
Incident Report for Twilio
Resolved
All services are operating normally.
Posted 11 months ago. Mar 11, 2017 - 00:20 PST
Investigating
We are currently seeing a delivery delay for inbound SMS messages to Mexico Twilio numbers.
Posted 11 months ago. Mar 11, 2017 - 00:13 PST
This incident affected: Programmable SMS (SMS).