Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Zipwhip Gateway
      Issues related to Zipwhip's Services
        Scheduled maintenance
        System Metrics

        Intermittent SMS/MMS Deliverability Issues to AT&T Due to Incorrect Deactivation Data

        Incident Report for Twilio

        Resolved

        Twilio experienced degraded service on a subset of US short codes for approximately 48 hours between March 5th and March 7th, 2025. During this period, customers may have experienced message delivery failures to AT&T numbers due to certain numbers being incorrectly marked as deactivated in the operator’s data file. The issue has been resolved as of March 7th at 13:34 UTC.
        Posted Mar 12, 2025 - 09:12 PDT

        Investigating

        Our monitoring systems have detected a potential issue with number deactivation. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
        Posted Mar 12, 2025 - 09:03 PDT