Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Unable to Recharge Funds; Accounts Suspended
Incident Report for Twilio
Resolved
All services are operating normally.
Posted 6 months ago. Aug 31, 2018 - 16:48 PDT
Identified
We've identified an issue with our payment system causing accounts to go to a suspended state. Charges and Recharges were unable to be processed. Our engineers are actively working to resolve.
Posted 6 months ago. Aug 31, 2018 - 13:17 PDT
This incident affected: TWILIO PLATFORM (Billing).