Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Failures to Telecel Network in Zimbabwe for Non-OTP Messages
      Incident Report for Twilio
      Resolved
      We continue experiencing SMS delivery failures when sending non-OTP messages to Telecel Network in Zimbabwe. Since the impact is limited to a small set of customers, we are closing this incident post and will reach out to these customers individually for further follow-ups.
      Posted Jun 12, 2023 - 14:11 PDT
      Update
      We continue experiencing SMS delivery failures when sending non-OTP messages to Telecel Network in Zimbabwe. Since the impact is limited to a small set of customers, we are closing this incident post and will reach out to these customers individually for further follow-ups.
      Posted Jun 12, 2023 - 14:10 PDT
      Update
      We continue to experience SMS delivery failures when sending non-OTP messages to Telecel Network in Zimbabwe. Our engineers are working with our carrier partner to get a prompt resolution. We expect to have new updates in 24 hours or as soon as more information becomes available.
      Posted Jun 12, 2023 - 10:26 PDT
      Update
      We continue to experience SMS delivery failures when sending non-OTP messages to Telecel Network in Zimbabwe. Our engineers are working with our carrier partner to get a prompt resolution. We expect to have new updates in 24 hours or as soon as more information becomes available.
      Posted Jun 11, 2023 - 14:29 PDT
      Update
      We continue to experience SMS delivery failures when sending non-OTP messages to Telecel Network in Zimbabwe. Our engineers are working with our carrier partner to get a prompt resolution. We expect to have new updates in 24 hours or as soon as more information becomes available.
      Posted Jun 10, 2023 - 14:43 PDT
      Update
      We continue to experience SMS delivery failures when sending non-OTP messages to Telecel Network in Zimbabwe. Our engineers are working with our carrier partner to get a prompt resolution. We expect to have new updates in 24 hours or as soon as more information becomes available.
      Posted Jun 09, 2023 - 14:49 PDT
      Update
      We continue to experience SMS delivery failures when sending non-OTP messages to Telecel Network in Zimbabwe. Our engineers are working with our carrier partner to get a prompt resolution. We expect to have new updates in 24 hours or as soon as more information becomes available.
      Posted Jun 08, 2023 - 14:47 PDT
      Update
      We continue to experience SMS delivery failures when sending non-OTP messages to Telecel Network in Zimbabwe. Our engineers are working with our carrier partner to get a prompt resolution. We expect to have new updates in 24 hours or as soon as more information becomes available.
      Posted Jun 07, 2023 - 14:51 PDT
      Update
      We continue to experience SMS delivery failures when sending non-OTP messages to Telecel Network in Zimbabwe. Our engineers are working with our carrier partner to get a prompt resolution. We expect to have new updates in 24 hours or as soon as more information becomes available.
      Posted Jun 06, 2023 - 14:43 PDT
      Update
      We continue to experience SMS delivery failures when sending non-OTP messages to Telecel Network in Zimbabwe. Our engineers are working with our carrier partner to got a prompt resolution. We expect to have new updates in 24 hours or as soon as more information becomes available.
      Posted Jun 05, 2023 - 14:49 PDT
      Update
      We continue to experience SMS delivery failures when sending non-OTP messages to Telecel Network in Zimbabwe. Our engineers are working with our carrier partner to got a prompt resolution. We expect to have new updates by June 5 2023 at 14:50 Pacific time or as soon as more information becomes available.
      Posted Jun 01, 2023 - 14:50 PDT
      Update
      We continue to experience SMS delivery failures when sending non-OTP messages to Telecel Network in Zimbabwe. Our engineers are working with our carrier partner to got a prompt resolution. We expect to have new updates by June 1 2023 at 14:53 Pacific time or as soon as more information becomes available.
      Posted May 30, 2023 - 14:53 PDT
      Update
      We continue to experience SMS delivery failures when sending messages to Telecel Network in Zimbabwe. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 24 hours (daily) or as soon as more information becomes available.
      Posted May 29, 2023 - 14:54 PDT
      Update
      We continue to experience SMS delivery failures when sending messages to Telecel Network in Zimbabwe. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 24 hours (daily) or as soon as more information becomes available.
      Posted May 28, 2023 - 15:16 PDT
      Update
      We continue to experience SMS delivery failures when sending messages to Telecel Network in Zimbabwe. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 24 hours (daily) or as soon as more information becomes available.
      Posted May 27, 2023 - 15:10 PDT
      Update
      We continue to experience SMS delivery failures when sending messages to Telecel Network in Zimbabwe. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 24 hours (daily) or as soon as more information becomes available.
      Posted May 26, 2023 - 15:20 PDT
      Update
      We continue to experience SMS delivery failures when sending messages to Telecel Network in Zimbabwe. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 24 hours (daily) or as soon as more information becomes available.
      Posted May 25, 2023 - 15:28 PDT
      Update
      We have confirmed that OTP messages are being correctly processed, the problem persist with non OTP messages. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 24 hours (daily) or as soon as more information becomes available.
      Posted May 24, 2023 - 16:16 PDT
      Update
      We continue to experience SMS delivery delays when sending messages to Telecel Network in Zimbabwe. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 24 hours (daily) or as soon as more information becomes available.
      Posted May 23, 2023 - 23:38 PDT
      Update
      We continue to experience SMS delivery delays when sending messages to Telecel Network in Zimbabwe. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 24 hours (daily) or as soon as more information becomes available.
      Posted May 22, 2023 - 23:59 PDT
      Update
      We continue to experience SMS delivery delays when sending messages to Telecel Network in Zimbabwe. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 16 hours or as soon as more information becomes available.
      Posted May 22, 2023 - 07:07 PDT
      Update
      We continue to experience SMS delivery delays when sending messages to Telecel Network in Zimbabwe. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 8 hours or as soon as more information becomes available.
      Posted May 21, 2023 - 23:10 PDT
      Update
      We continue to experience SMS delivery delays when sending messages to Telecel Network in Zimbabwe. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 4 hours or as soon as more information becomes available.
      Posted May 21, 2023 - 19:15 PDT
      Update
      We continue to experience SMS delivery delays when sending messages to Telecel Network in Zimbabwe. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted May 21, 2023 - 17:23 PDT
      Update
      We are experiencing SMS delivery delays when sending messages to Telecel Network in Zimbabwe. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted May 21, 2023 - 16:25 PDT
      Investigating
      Our monitoring systems have detected a potential issue with SMS messages to Zimbabwe. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted May 21, 2023 - 16:20 PDT
      This incident affected: CARRIER NETWORK (SMS, Middle East & Africa).