Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Message Delivery Issues to T-Mobile Subscribers from Twilio Long Codes, is Resolved
      Incident Report for Twilio
      Resolved
      We are no longer experiencing delivery failures to US T-Mobile. This incident has been resolved.
      Posted Jul 15, 2020 - 17:02 PDT
      Update
      We are observing successful SMS delivery to US T-Mobile. We will continue to monitor to ensure a full recovery.
      Posted Jul 15, 2020 - 16:21 PDT
      Update
      We are observing successful SMS delivery to US T-Mobile. We will continue to monitor to ensure a full recovery.
      Posted Jul 15, 2020 - 16:13 PDT
      Monitoring
      We are observing successful SMS delivery to US T-Mobile for the last 10 minutes. We will continue to monitor to ensure a full recovery.
      Posted Jul 15, 2020 - 15:46 PDT
      Update
      We are experiencing message delivery failures to a subset of messages to US T-Mobile from Twilio long codes. We will provide an update as soon as we have additional information.
      Posted Jul 15, 2020 - 15:38 PDT
      Update
      We are experiencing message delivery failures to a subset of messages to US T-Mobile from Twilio long codes. We will provide an update as soon as we have additional information.
      Posted Jul 15, 2020 - 15:35 PDT
      Investigating
      Our monitoring systems have detected a potential issue sending message to T-Mobile subscribers. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Jul 15, 2020 - 15:18 PDT
      This incident affected: CARRIER NETWORK (SMS Long Code, North America).